Import data into Minitab

You can import data from files created by many other applications. There are several ways you can import data into Minitab.

Option Instructions

Open the file in Minitab

Choose File > Open to open the following types of files directly in Minitab:
  • Minitab (.mtw, .mpj, .mgf)
  • Microsoft Excel (.xls, .xlsx, .xml)
  • Text (.txt, .dat, .csv)

For more information, see Open a file.

Copy/paste data

You can copy data from Excel or other programs and paste the data into Minitab.

You can also copy data from the Minitab Session window and paste it into the worksheet. Follow these steps:
  1. Press and hold the Alt key, and select only the column that you want to copy in the Session window.
  2. Choose Edit > Copy to copy the selected portion of the output.
  3. Click in the cell in the worksheet where you want the column to start.

    If you are copying column labels along with your data, be sure to click in the column name cells of the Minitab worksheet.

  4. Choose Edit > Paste Cells.

Query a database by using ODBC

ODBC (Open Database Connectivity) is a protocol that is used by many applications to import data from database files. With ODBC, you can collect data in a database application such as Access or dBase, and then import the data into Minitab.

To set up ODBC to import data, choose File > Query Database (ODBC). For more information, see Import data from a database by using ODBC.

Create a hot link to another application by using DDE

DDE (Dynamic Data Exchange) is a protocol that is used by many applications to exchange data. You can use DDE to exchange data between Minitab and other applications. You can add "hot links" to external applications such as Excel, so that when values change in Excel, they are automatically updated in Minitab. Also, you can hot link columns from Minitab to Excel, so that when they change in Minitab, they are automatically updated in Excel.

To create a hot link with DDE, choose Edit > Worksheet Links > Manage Links. For more information, see Exchange data with other applications by using DDE.

Important

Starting with Windows Vista, Microsoft no longer supports DDE on a network. However, you can create DDE links on a local machine.

By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy