Customizing Minitab

Overview

Minitab has several tools for changing default options or creating custom toolbars and keyboard shortcuts.

Use Tools > Options to change the default options for many Minitab features such as the following:
  • Program settings (such as memory usage, initial directory, window layout, and dialog boxes)
  • Worksheets and the Session window
  • Statistical commands
  • Graphs
Use Tools > Customize to do the following:
  • Assign a shortcut key to a menu item.
  • Set options for how Minitab displays toolbars.
  • Create custom icons for menu items or toolbar buttons.

You finished your first analysis and generated a report. You now decide to use Tools > Options and Tools > Customize to customize the Minitab interface to make future analyses quicker and easier.

Set options

You can change many options during a Minitab session, such as changing graph display options or enabling the session command prompt. However, when you close Minitab, these options revert to the default settings.

If you want an option to be a default option for all Minitab sessions, use Tools > Options. Options that you change remain active until you change them again.

Note

You can restore Minitab’s default options at any time. For more information, see the section "Restore Minitab's default options" below.

Add an automatic footnote

Because you will create the same graphs with similar data in the future, you need a way to distinguish the results of each analysis. You decide to add an automatic footnote to your graphs to include the worksheet name and the modification date.

  1. If you are continuing from the previous chapter, choose File > New > Project. If not, start Minitab.
  2. Choose Help > Sample Data.
  3. Double-click the Getting Started folder, then double-click ShippingData.MTW.
  4. Choose Tools > Options. Expand Graphics, expand Annotation, then select My Footnote.
  5. Under Information to include in my footnote, select Worksheet name and Date the graph was last modified.
  6. In Custom text, enter Shipping center efficiency.
  7. Click OK.

With these options, each time you create a graph, Minitab adds the footnote.

Create a histogram to view the footnote

To see an example of the automatic footnote, create a histogram.

  1. Choose Graph > Histogram.
  2. Click With Fit, then click OK.
  3. In Graph variables, enter Days.
  4. Click Multiple Graphs.
  5. On the By Variables tab, in By variables with groups in separate panels, enter Center.
  6. Click OK in each dialog box.

Create a custom toolbar

Use Tools > Customize to create new menus and toolbars that contain the commands that you use frequently.

Create a toolbar

During some analyses, you return to the same menu items many times. You can simplify future analyses if you add these items to a custom toolbar.

Create a custom toolbar that includes some of the commands that you used in the shipping data analysis.

  1. Choose Tools > Customize.
  2. On the Toolbars tab, click New.
  3. In Toolbar Name, enter Shipping Data.
  4. Click OK.

Minitab creates the blank toolbar, and the new toolbar is displayed in the toolbar list.

Add commands to the toolbar

In the shipping data analysis, you used Graph > Histogram and Assistant > Graphical Analysis > Scatterplot (Groups). Add these commands to the blank toolbar.

  1. Drag the blank toolbar to dock it beside an existing Minitab toolbar.
  2. On the Commands tab, under Categories, select Graph.
  3. Under Commands, select Histogram.
  4. Drag Histogram to the new toolbar.
  5. Under Categories, select Assistant.
  6. Under Commands, select Scatterplot (Groups).
  7. Drag Scatterplot (Groups) to the new toolbar.
  8. Click Close.
Tip

You can also create a custom menu. For more information about Tools > Customize, go to Customize in the Minitab Help index. To access the Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.

Assign a shortcut key

Minitab contains many shortcut keys for frequently used functions. You can also assign shortcut keys for the commands that you use often. To assign shortcut keys, use Tools > Customize > Keyboard.

Because you often create histograms for your shipping data analysis, you want to assign a shortcut key for this command.

  1. Choose Tools > Customize.
  2. On the Keyboard tab, from Category, select Graph.
  3. Under Commands, select Histogram.
  4. Click in Press New Shortcut Key.
  5. Press Ctrl+Shift+H.
    Under Press New Shortcut Key, the Assigned to text displays the current status of the selected shortcut key combination. In this case, the text is [Unassigned]. Keys or key combinations that are already assigned to a command are displayed here. You must remove any existing key combination that conflicts with your choice before that key combination can be assigned to a new command.
  6. Click Assign.
    The new shortcut key appears under Current Keys.
  7. Click Close.

You can now access the Histogram gallery by pressing Ctrl+Shift+H.

Tip

For a list of Minitab’s default shortcut keys, choose Help > Keyboard Map or go to Shortcut keys in the Minitab Help index. To access the Minitab Help index, open Minitab, choose Help > Help, then click the Index tab in the left pane.

Restore Minitab's default options

Any options that you change, as well as any changes that you make to date/time settings or value order settings, are stored in a profile. You can enable and disable this profile using Tools > Manage Profiles. You also can export and share this profile with other users.

All options that you adjusted while you worked through Getting Started with Minitab 17 are already stored in your active profile. Disable the current profile to restore Minitab’s default options and change the name of the profile to use for future shipping center analyses.

  1. Choose Tools > Manage Profiles.
  2. Move MyProfile from Active profiles to Available profiles.
  3. In Available profiles, double-click MyProfile and enter ShippingCenterAnalysis.
  4. Click OK.

The default options are now restored. Minitab creates a new active profile to store any additional changes that you make.

To enable the options that you adjusted during your Getting Started with Minitab 17 sessions, move the current active profile to Available profiles, move ShippingCenterAnalysis to Active profiles, and then click OK.

Note

You can also reset Minitab’s default options by double-clicking the shortcut named Restore Minitab Defaults English located in the English folder under the main Minitab 17 folder that is installed on your hard drive. Export any profiles that you want to keep before you run this program.

Save the project

Save all your work in a Minitab project.

  1. Choose File > Save Project As.
  2. Browse to the folder that you want to save your files in.
  3. In File name, enter MyCustomize.
  4. Click Save.
By using this site you agree to the use of cookies for analytics and personalized content.  Read our policy